Optiplex 320 problemático!

abril 19, 2007 às 19:00 | Publicado em linux, problemas | 3 Comentários

Slackware, Debian, OpenSuSE, Gentoo e Ubuntu: TODAS congelaram em algum momento, seja no boot, ou na inicialização depois de instalado. Esse problema foi encontrado nas 11 optiplex do local!

A única distribuição que consegui, foi o pre-release do Ubuntu Feisty, mas após instalação ele não iniciava com o grub, sempre numa tela preta congelada. Baixei o Ubuntu Feisty que foi lançado hoje para testar, e infelizmente o grub continuou congelando! Então resolvi tentar com o LILO e obtive sucesso! Acompanhe os macetes abaixo:

Após dar o boot com o Ubuntu Feisty 7.04, abra o terminal e assuma o root. Em seguida monte a partição previamente instalada:

ubuntu@ubuntu:~$ sudo su -
root@ubuntu:~# mount /dev/sda3 /mnt

Precisamos agora espelhar os dispositivos dinâmicos que o udev do kernel 2.6 cria na inicialização no /dev e também o /proc. Com isso podemos tornar o /mnt nossa nova raiz:

root@ubuntu:~# mount --bind /dev /mnt/dev
root@ubuntu:~# mount -t proc proc /mnt/proc
root@ubuntu:~# chroot /mnt
root@ubuntu:/#

Agora vamos fazer download dos binários do LILO e extrair na raiz, assim os binários irão ficar em seus devidos lugares. Em seguida o lilo.conf é criado com a configuração abaixo:

root@ubuntu:/# wget http://home.san.rr.com/johninsd/pub/linux/lilo/lilo-22.8.bin.tar.gz
root@ubuntu:/# tar xf lilo-22.8.bin.tar.gz
root@ubuntu:/etc# cat lilo.conf
boot=/dev/sda
prompt
timeout = 50
vga=791
lba32
image = /boot/vmlinuz-2.6.20-15-386
initrd = /boot/initrd.img-2.6.20-15-386
root = /dev/sda3
label = Ubuntu_Feisty
append="root=/dev/sda3"
read-only
root@ubuntu:~# lilo
Added Ubuntu_Feisty *
root@ubuntu:~#

Sim, foi necessário o append=”root=/dev/sda3″, apesar root acima já especificado.

Agora basta reiniciar o sistema e veja iniciando normalmente! 😀

Anúncios

Blog no WordPress.com.
Entries e comentários feeds.